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ECE 141 Spring 2010

Test III - Part II
Michael R. Gustafson II

Name (please print)

In keeping with the Community Standard, I have neither provided nor received any assistance on this test. I understand if
it is later determined that I gave or received assistance, I will be brought before the Undergraduate Judicial Board and, if
found responsible for academic dishonesty or academic contempt, fail the class. I also understand that I am not allowed to
speak to anyone except the instructor about any aspect of this test until the instructor announces it is allowed. I understand
if it is later determined that I did speak to another person about the test before the instructor said it was allowed, I will be
brought before the Undergraduate Judicial Board and, if found responsible for academic dishonesty or academic contempt,
fail the class.

Signature:

Instructions for Written and Discussion Sections

There are some problems that require you to describe a controller, or to report values from a design or a simulation, or to
explain why you expect the second-order assumption to work or not. Be sure to indicate which part of a problem you are
answering and put your name on the paper. As always, only put answers to one problem on a page. Note that there is a
“summary page” for each problem where you will record information such as controller gains, closed-loop poles and zeros,
and transient response characteristics.

Instructions for Computer-Based Sections

All your files for this test will be placed in a directory on your OIT account. There are two scripts you will be running to set
everything up. The first - StartTest3 - will create a folder called ECE141TEST3 in your account and then set the permissions
such that I can look at the files. You must make sure all your scripts, worksheets, and graphs end up in this folder. The
second - EndTest3 - will send me a snapshot of the directory contents and lock the directory from further changes. After I
receive the e-mail, I will copy the directory contents to another location and delete the originals. Be sure to use the stated
names for files in those problem parts requiring JPEG images.

To run the StartTest3 script, log into your UNIX account and type:

˜mrg/ pub l i c /ECE141/ Star tTest3

Similarly, when you are finished and ready to lock your directory, type:

˜mrg/ pub l i c /ECE141/EndTest3

Also see the next page for instructions on creating and saving plots.



Titling, Naming, and Saving Files

For this test, in order to conserve space, you will be using the JPEG format instead of PostScript. The following instructions
will lead you through the process of saving both root locus plots and LTIview plots.

Root Locus Plots

After opening SISOtool, within the Control and Estimation Tools Manager window, before starting the design process:

(a) First, go to the and click on the Graphical Tuning tab. For Plot 2 and Plot 3, turn the Plot Type to None.

(b) Next, go to the Edit menu and select SISO Tool Preferences. In the Options tab, be sure to set the Tuned Parameters

to Zero/pole/gain.

Once you have the root locus you want complete with setting the gain, zeros, and poles where they need to be, do the
following in the SISO Design window (the window with the root locus in it):

(a) Right-click inside the whitespace in the editor plot and bring up the Properties menu.

(b) Within the Labels tab, change the title making sure to include the problem part and your NET ID. For example, for
the first root locus, change the title to Root Locus Problem 1a (NETID).

(c) Go to the File menu and select Save Session. Select the SISO Design Task then click OK. When the Save Projects

box comes up, give the session the name of the problem you are working on - for example Problem1a. This will save the
information contained within the Root Locus in a way that can be retrieved later should something happen to the plot
file.

(d) Again go to the File menu, and select Print to Figure. This will bring up a figure window containing the same
information as the Root Locus editor plot, including the figure title.

(e) Within the File menu of the figure window, select Save As. In the Save As box, change the Save as type to JPEG

image (*.jpg) and save the file with the name given in that portion of the test. For example, for the first root locus of
Problem 1, you would use RootLocus1a.jpg.

LTI Viewer Plots

First, get the plot where it needs to be with respect to showing the relevant characteristics (OS%, settling time, and steady
state values). Also be sure to turn off the Closed Loop: r to u (green) system. Then:

(a) Right-click inside the whitespace in the response plot and bring up the Properties menu.

(b) Within the Labels tab, change the title making sure to include the problem part and your NET ID. For example, for
the first step response, change the title to Step Response Problem 1a (NETID).

(c) Go to the File menu of the LTI Viewer and select Print to Figure. This will bring up a figure window containing the
same information as the viewer, including the figure title. Note that you will need to click back on the points to get the
informational boxes related to system characteristics (peak time, etc.).

(d) Within the File menu of the figure window, select Save As. In the Save As box, change the Save as type to JPEG

image (*.jpg) and save the file with the name given in that portion of the test. For example, for the first step response
of Problem 1, you would use StepResponse1a.jpg.



Name (please print):
Community Standard (print ACPUB ID):

Problem I: [40 pts.] System I

Given the block diagram of a control system in Figure 1.6b on p. 8, where the Input Transducer and Output
Transducer are both unity, the frequency model of the controller is initially some constant K, and the frequency
model of the plant is

G =
1

(s + 15)(s + 10)(s + 7)(s − 2)

Gain Control

(a) Generate a root locus plot for K > 0.

(b) On the discussion page, state the range of valid positive K for this system to remain stable. You can
determine this graphically and do not need to save this particular gain’s root locus as a JPEG.

(c) Assume that you want the system to have a step response with a damping ratio ζ = 0.7070. Determine the
gain value K to accomplish this design point and call this System 1a. Record the transfer function for the
controller and determine the locations of the closed loop poles and zeros of the overall system, the values of
the static error constant of position and steady state error for a step input, and the OS% and settling time
predicted using the second-order assumption.

(d) Using the information in the introduction to the test, change the root locus plot title to “Root Locus Problem
1a (NETID)” where NETID is your NETID and save the file as RootLocus1a.jpg.

(e) Generate a simulation of the step response and label the simulated values of OS%, settling time, and steady
state response. Then change the plot title to “Step Response Problem 1a (NETID)” and save it as a JPEG
file called StepResponse1a.jpg. Find and record the simulated values for steady state position error, OS%,
and settling time on the summary sheet, then state on the discussion page if the transient characteristics in
the simulation match well with your design values based on the 2nd order assumption and why that might
be the case. Be sure to show any calculations needed for items such as the steady state error.

Transient Response Design

(f) Now assume that you want the system to have the same damping ratio but you need it to settle in one-half
the simulated settling time in System 1a - this will be System 1b. Graphically determine the transfer function
of a controller that will allow this to happen while being likely to have the system continue to satisfy the
second-order assumptions. Record the transfer function for the entire controller and determine the locations
of the closed loop poles and zeros of the overall system, the values of the static error constant of position
and steady state error for a step input, and the OS% and settling time predicted using the second-order
assumption.

(g) Leaving the gain set to achieve the design point, change the root locus plot title to “Root Locus Problem 1b
(NETID)” and save the file as RootLocus1b.jpg.

(h) Generate a simulation of the step response and label the simulated values of OS%, settling time, and steady
state response. Then change the plot title to “Step Response Problem 1b (NETID)” and save it as a JPEG
file called StepResponse1b.jpg. Find and record the simulated values for steady state position error, OS%,
and settling time on the summary sheet, then state if the transient characteristics match well with your
design values based on the 2nd order assumption and why that might be the case.



Steady State Error Correction

(i) Design a passive compensator to place in series with the controller above to reduce the steady state error
by a factor of four. Record the transfer function for the entire controller-including the one used above to fix
the transient response - and determine the locations of the closed loop poles and zeros of the overall system
and the values of the static error constant of position and steady state error for a step input.

(j) Leaving the gain set to achieve this final design point, change the root locus plot title to “Root Locus
Problem 1c (NETID)” and save the file as RootLocus1c.jpg.

(k) Generate a simulation of the step response and label the simulated value of the steady state response. Then
change the plot title to “Step Response Problem 1c (NETID)” and save the file as StepResponse1c.jpg.
Find and record the simulated values for steady state position error, and overall settling time on the summary
sheet, then state on the discussion sheet if the steady state error matches well with your calculated steady
state error.



Summary Sheet - Problem 1

Design Values - Using Dominant 2nd Order Assumptions!!

Sys. Controller CL Poles CL Zeros Kp estep(∞) OS% ts

1a

1b

1c N/R N/R

Simulation Values - From Simulation!!

Sys. estep(∞) OS% ts

1a

1b

1c N/R



Discussion



Name (please print):
Community Standard (print ACPUB ID):

Problem II: [30 pts.] System II

Given the block diagram of a control system in Figure 1.6b on p. 8, where the Input Transducer and Output
Transducer are both unity, the frequency model of the controller is initially some constant K, and the frequency
model of the plant is

G =
s2 + 40s + 416

(s)(s + 7)(s + 25)

Gain Control

(a) Generate a root locus plot for K > 0.

(b) On the discussion page, state the range of valid positive K for this system to be stable. You can determine
this graphically and do not need to save this particular gain’s root locus as a JPEG.

(c) Determine the smallest possible damping ratio that can be obtained for this particular system and list this
value on the discussion page for this problem. How did you determine that value?

(d) Assume that you want the system to have a step response with 1% overshoot and the best chance of the 2nd
order assumptions working as possible with just a gain controller. Determine the gain value K to accomplish
this design point and call this System 2a. Record the transfer function for the controller and determine the
locations of the closed loop poles and zeros of the overall system, the values of the static error constant of
velocity and steady state position error for a ramp input, and the OS% and settling time for a step response
predicted using the second-order assumption.

(e) Using the information in the introduction to the test, change the plot title to “Root Locus Problem 2a
(NETID)” where NETID is your NETID and save the file as RootLocus2a.jpg.

(f) Generate a simulation of the step response and label the simulated values of OS%, settling time, and steady
state response. Then change the plot title to “Step Response Problem 2a (NETID)” and save it as a JPEG
file called StepResponse2a.jpg. Find and record the simulated values for OS% and settling time on the
summary sheet, then state if the transient characteristics match well with your design values and why that
might be the case.

Transient Response Design

(g) Now assume that you want the system to have a settling time of 0.5 sec with a 1% OS - this will be System
2b. Graphically determine the transfer function of a controller that will allow this to happen while still
keeping it likely that the 2nd order assumptions apply. Record the transfer function for the entire controller
and determine the locations of the closed loop poles and zeros of the overall system, the values of the static
error constant of velocity and steady state position error for a ramp input, and the OS% and settling time
predicted using the second-order assumption.

(h) Leaving the gain set to achieve the design point, change the root locus plot title to “Root Locus Problem 2b
(NETID)” and save the file as RootLocus2b.jpg.

(i) Generate a simulation of the step response and label the simulated values of OS%, settling time, and steady
state response. Then change the plot title to “Step Response Problem 2b (NETID)” and save it as a JPEG
file called StepResponse2b.jpg. Find and record the simulated values for OS% and settling time on the
summary sheet, then state if the transient characteristics match well with your design values and why that
might be the case.



Steady State Error Correction

(j) Design an active compensator to place in series with the one above to raise the system type - this will be
System 2c. Record the transfer function for the controller and determine the locations of the closed loop
poles and zeros of the overall system and the values of the static error constant of velocity and steady
state position error for a ramp input. You should make sure that your controller neither interferes with the
transient response nor takes longer than approximately four minutes to correct the steady state error..

(k) Leaving the gain set to achieve this final design point, change the root locus plot title to “Root Locus
Problem 2c (NETID)” and save the file as RootLocus2c.jpg.

(l) Generate a simulation of the step response and label the simulated value of the steady state response. Then
change the plot title to “Step Response Problem 2c (NETID)” and save the file as StepResponse2c.jpg.



Summary Sheet - Problem 2

Design Values - Using Dominant 2nd Order Assumptions!!

Sys. Controller CL Poles CL Zeros Kv eramp(∞) OS% ts

2a

2b

2c N/R N/R

Simulation Values - From Simulation!!

Sys. OS% ts

2a

2b

2c N/R



Discussion


